Web interface only: Reports of elevated errors
Incident Report for Files.com
Postmortem

From 11:37 AM PST to 1:24PM PST, a small number of Files.com customers experienced errors in the web interface when viewing some pages.  This was caused by a JavaScript bug introduced during a routine update, related to rendering pages with “tab-like” navigation.  Because the buggy behavior impacted only a small number of pages, it was not detected during our routine testing.

Our monitoring systems did record an increase in frontend error rates, however the increase in errors was not high enough to raise an alert and instead we were alerted to this bug through our customer support channel.

As a result of this incident, we have reduced the alerting threshold for similar front end errors. We expect that we will now detect and resolve similar incidents in the future.

Posted Nov 25, 2024 - 07:08 PST

Resolved
Files.com has resolved an incident that caused elevated errors on the web interface.

No other services were impacted by this incident.

Certain pages in the web interface failed to load between 11:37am and 1:24pm Pacific time.

We are still investigating this incident and compiling a Root Cause Analysis, which we will post here.
Posted Nov 06, 2024 - 11:30 PST