SFTP, FTP, and WebDAV services only: Elevated error rates
Incident Report for Files.com
Postmortem

On October 29th from 10:29 am PST until 10:36am PST, Files.com customers experienced considerably higher error rates for FTP, SFTP, and WebDAV requests. No other Files.com services, including the Files.com API, were impacted during this window.

This incident began when we deployed a new version of the software package we use internally that contains our FTP, SFTP, and WebDAV software. The root cause of this incident was that the internal tool that we use for deploying software had an edge case bug that resulted in deployment failure if a large number of deployments were performed during the same day. We quickly identified the issue and deployed a fix.

We have added additional testing around this scenario and do not expect this issue to recur.

We greatly appreciate your patience and understanding as we resolved this issue. If you need additional assistance or continue to experience issues, please contact our Customer Support team.

Posted Nov 25, 2024 - 07:06 PST

Resolved
Files.com is aware of elevated error rates on the FTP, SFTP, and WebDAV services on Files.com in all regions from 10:29am to 10:36am Pacific Time.

We believe this incident impacted less than half of total traffic across these services during this time period.

This incident did not impact any other network services such as API, AS2, HTTP, or others.

We are compiling a Root Cause Analysis for this incident, which we will post here as soon as it is ready.
Posted Oct 29, 2024 - 10:30 PDT