SSL Certificate Errors from non-US regions
Incident Report for Files.com
Resolved
All services have been restored and are operating normally. As of 5:25 AM PST, a fix has been implemented and we will continue to monitor the results. This incident was the result of a regional SSL Certificate misconfiguration issue and not a security breach.

If you need additional support, please do not hesitate to contact our Customer Success team by email, live chat, or phone. Thanks for your support while we resolved this issue.
Posted Sep 03, 2019 - 05:28 PDT
Identified
We have identified the cause and are working to implement a fix. We will post an update as soon as all services are restored to normal, and continue to monitor to confirm resolution. If you need additional assistance, please do not hesitate to contact our Customer Success team by email, chat or phone. Thank you for your patience.
Posted Sep 03, 2019 - 05:18 PDT
Update
We are continuing to investigate this issue. We will post an update as soon as the issue has been identified and a fix is being implemented. If you need additional assistance, please do not hesitate to contact our Customer Success team by email, chat or phone. Thank you for your continued patience.
Posted Sep 03, 2019 - 05:11 PDT
Investigating
We are actively investigating reports of SSL certificate errors on the Files.com / BrickFTP from non-US regions. We will provide additional details as they become available. Customers with urgent questions are encouraged to contact our Customer Success team by email. Thank you for your patience.
Posted Sep 03, 2019 - 04:58 PDT
This incident affected: Web Interface, FTP/FTPS, SFTP, and WebDAV.