Reports of Elevated DNS Errors
Incident Report for Files.com
Postmortem

On May 12th, 2023, at  AM/PM PST, Files.com received customer reports of elevated DNS errors which resulted in an incident being declared.  The Incident Management Team (IMT) convened and immediately began investigation. 

Files.com released an initial Status Page posting on May 12th, 2023, at 3:45 PM PST stating: 

“Reports of Elevated DNS Errors:  We are investigating reports of DNS errors on the Files.com service.    

This is intermittently affecting some logins for all services. 

We will provide additional details as they become available. Customers with urgent questions are encouraged to contact our Customer Support team by email. Thank you for your patience.” 

The elevated DNS errors was resolved on May 12th, 2023, at 4:16 PM PST, returning the platform to full functionality. 

Files.com released a resolution Status Page posting on May 12th, 2023, at 4:23 PM PST stating 

“All services have been restored and are operating normally.  

We resolved a DNS issue resulting in some intermittent errors on accessing Files.com sites. Users without the site name cached were potentially affected from approximately 2:25 p.m. PST to 4:16 p.m. PST.  This issue did not anyone with dedicated IP addresses.   

We will follow up with an Incident Report within ten (10) business days including the root cause and steps taken to address the root cause. If you need additional support, please do not hesitate to contact our Customer Support team by email or phone. Thanks for your support while we resolved this issue.” 

This incident occurred during the deployment of changes to our corporate domain registrations as part of the post-mortem/resolution process for the incident that occurred on May 5.  As discussed in the RCA for that incident, we moved the registration records for all domain names owned by Files.com to CSC Domains, an enterprise and security-focused domain name registrar, for the purpose of mitigating domain name registrar risk.    

During the process of the domain transfer, the nameservers for one of our domain names were inadvertently entered incorrectly into the new registrar.  As a result, DNS lookups for certain domains resulted in failure.  This issue only affected a subset of our customers, and did not affect any customers using custom domain names or custom IP addresses.   

Once we diagnosed the problem, we were able to call CSC Domains and get the matter resolved immediately.  As of now, all domains owned by Files.com are managed by CSC Domains, and we do not expect any further registrar-related incidents to occur in the future. 

We greatly appreciate your patience and understanding as we resolved this issue. If you need additional assistance or continue to experience issues, please contact our Customer Support team.

Posted Jun 01, 2023 - 11:21 PDT

Resolved
All services have been restored and are operating normally.

We resolved a DNS issue resulting in some intermittent errors on accessing Files.com sites. Users without the site name cached were potentially affected from approximately 2:25 p.m. PST to 4:16 p.m. PST. This issue did not anyone with dedicated IP addresses.

We will follow up with an Incident Report within ten (10) business days including the root cause and steps taken to address the root cause. If you need additional support, please do not hesitate to contact our Customer Support team by email or phone. Thanks for your support while we resolved this issue.
Posted May 12, 2023 - 16:23 PDT
Investigating
We are investigating reports of DNS errors on the Files.com service.

This is intermittently affecting some logins for all services.

We will provide additional details as they become available. Customers with urgent questions are encouraged to contact our Customer Support team by email. Thank you for your patience.
Posted May 12, 2023 - 15:45 PDT