Error Uploading, Downloading, and Previewing Files
Incident Report for Files.com
Postmortem

The Incident

On August 5th, 2019, 11:22 AM PST the Files.com team received reports that the application was unable to allow files to be transferred up or down via all methods.

The cause was determined to be a bug in an update script that was being deployed to provide new functionality. This bug was not found during the rigorous testing that occurred prior to the approval for production deployment.

The update script was rolled back and the system was fully functional at 12:12 PM PST. All methods of transferring files up or down were verified as working successfully.

We greatly appreciate your patience and understanding as we resolved this issue. If you need additional assistance or continue to experience issues, please contact our Customer Success team.

Lessons Learned

Files.com has reviewed internal processes and has implemented several updates including better communications to customers, better coordination of changes and modifications to the change management pre-approval testing process to better mirror production systems.

Posted 17 days ago. Aug 09, 2019 - 11:12 PDT

Resolved
All services have been restored and are operating normally. We identified that there was a connection and downloading issue impacting all protocols. As of 12:12pm PST, a fix has been implemented and we will continue to monitor the results. We will follow up with an Incident Report within ten (10) business days including the root cause and steps taken to address the root cause. If you need additional support, please do not hesitate to contact our Customer Success team by email, live chat, or phone. Thanks for your support while we resolved this issue.
Posted 21 days ago. Aug 05, 2019 - 12:26 PDT
Monitoring
All services have been restored and are operating normally. A fix has been implemented and we will continue to monitor the results. We will follow up with an Incident Report within ten (10) business days including the root cause and steps taken to address the root cause. If you need additional support, please do not hesitate to contact our Customer Success team by email, live chat, or phone. Thanks for your patience and support while we resolved this issue.
Posted 21 days ago. Aug 05, 2019 - 12:17 PDT
Update
We are continuing to investigate this issue.
Posted 21 days ago. Aug 05, 2019 - 12:03 PDT
Update
We are continuing to investigate this issue.
Posted 21 days ago. Aug 05, 2019 - 12:03 PDT
Update
Expanding scope to include connection failures via web interface and FTP/SFTP protocols. Our engineering team continues to work to find cause of the issue. Will continue to keep you updated via this status page.
Posted 21 days ago. Aug 05, 2019 - 12:01 PDT
Investigating
Files.com has received notice from customers where downloading files results in an error. We are actively investigating this issue and will provide additional updates as they become available. Customers with urgent questions are encouraged to contact our Customer Success team by email. Thank you for your patience.
Posted 21 days ago. Aug 05, 2019 - 11:52 PDT
This incident affected: Web Interface, FTP/FTPS, SFTP, WebDAV, and LDAP/Active Directory.