Upload Button Issue in Web Interface

Incident Report for Files.com

Postmortem

From 22:55 UTC on 7 July 2025 until 12:48 UTC on 8 July 2025 the “Upload Files” and “Upload Folder” buttons in the Files.com web interface did not respond when clicked. Drag-and-drop uploads, API uploads, and all other protocols continued to operate normally.

We deployed an update to our web interface intended to clean up an internal warning message. Unfortunately, that update removed the event handler that activates the file-picker dialog, rendering the Upload button inert. Because our automated tests and monitors did not exercise that specific UI path, the regression was not detected before release or by our monitoring systems. After customers reported the problem, we immediately rolled back the change, restoring normal operation.

We apologize for the inconvenience and frustration this incident caused. Our customers rely on Files.com for mission-critical workflows, and we did not meet that standard during this window. We are committed to learning from this event and preventing similar issues in the future.

Posted Aug 18, 2025 - 07:47 PDT

Resolved

We have resolved an intermittent issue that caused the Upload Files button in the web interface to become unresponsive. This issue was limited to the button functionality only—file uploads still worked correctly via drag-and-drop in the web interface, as well as through all other supported protocols. This incident occurred between 22:55 UTC on July 7 and 10:48 UTC on July 8.

Thank you for your patience while we investigated and addressed the problem.
Posted Jul 07, 2025 - 15:55 PDT