Share Links: Issues Impacting Usage
Incident Report for Files.com
Postmortem

On April 13th, 2023, at 5:59 PM PST, Files.com received customer reports of share link generation errors, which resulted in an incident being declared.  The Incident Management Team (IMT) convened and immediately began investigation. 

Files.com released an initial Status Page posting on April 13th, 2023, at 6:01 PM PST, stating:  

Share Links: Issues Impacting Usage:  We are resolving issues with generating Share Links on Files.com across all regions preventing usage of the app.”  

The share link generation errors were resolved on April 13th, 2023, at 6:05 PM PST, returning the platform to full functionality. 

Files.com released a resolution Status Page posting on April 13th, 2023, at 6:11 PM PST, stating:  

“We have resolved an issue that was preventing usage of generating new Share Links in all regions.  This incident occurred between the times of 17:39 PST to 18:05 PST.” 

 This incident was caused by accidental merge of a non-passing build of our API environment to production while attempting to resolve another incident.  During our process of incident handling, we bypass certain internal test processes to expedite the resolution of the incident.  In this case, the issue was immediately detected by the incident management team and a fix was pushed quickly.  However, it took nearly 12 minutes to test and deploy the fix, resulting in a 12 minute impact to share link creation. 

As a result of this (and related) incidents, Files.com has implemented major improvements to the speed of its testing and deployment process.  We expect to be able to deploy fixes such as the one in the future in 2-3 minutes as opposed to 12 minutes. 

Extensive review and testing was conducted by Files.com staff to ensure this resolution, and we have already taken steps internally to prevent this issue from recurring in the future.   

We greatly appreciate your patience and understanding as we resolved this issue. If you need additional assistance or continue to experience issues, please contact our Customer Support team.

Posted May 15, 2023 - 10:38 PDT

Resolved
We have resolved an issue that was preventing usage of generating new Share Links in all regions. This incident occurred between the times of 17:39 PST to 18:05 PST.
Posted Apr 13, 2023 - 18:11 PDT
Identified
We are resolving issues with generating Share Links on Files.com across all regions preventing usage of the app.

We will provide additional details as they become available. Customers with urgent questions are encouraged to contact our Customer Support team by email. Thank you for your patience.
Posted Apr 13, 2023 - 18:01 PDT
This incident affected: Web Interface.