Delays To Batch and Scheduled Operations; Performance Degradation and/or High Error Rates
Incident Report for Files.com
Resolved
All services have been restored and are operating normally.

We have resolved a situation causing delays to batch and scheduled operations, including but not limited to scheduled and ad-hoc syncs, moves, copies, file transformations, automations, webhooks, batch deletes, email delivery, previews, and similar batch operations. We have also resolved a performance degradation on Files.com which affected all Files.com core and auxiliary services in all regions.

This incident occurred during the late evening hours of October 5th until approximately 9:00 a.m Pacific on 10/6.

We will follow up with an Incident Report within ten (10) business days including the root cause and steps taken to address the root cause. If you need additional support, please do not hesitate to contact our Customer Support team by email or phone. Thanks for your support while we resolved this issue.
Posted Oct 06, 2023 - 10:24 PDT
Identified
We have identified the cause of the operational delays for batch and scheduled operations and are working to implement a fix. At this time, the vast majority of batch and scheduled operations are caught up, but there is a small minority of jobs that are still impacted.

We have resolved a real-time operations performance degradation on Files.com which affected all Files.com core and auxiliary services in all regions. Real-time operations, such as FTP, SFTP, AS2, and other operations where Files.com acts as a server, should be back to normal performance.

We will post an update as soon as all services are restored to normal, and continue to monitor to confirm resolution.

If you need additional assistance, please do not hesitate to contact our Customer Support team by email. Thank you for your patience.
Posted Oct 06, 2023 - 07:44 PDT
Investigating
We are investigating reports of delays to batch and scheduled operations, including but not limited to scheduled and ad-hoc syncs, moves, copies, file transformations, automations, webhooks, batch deletes, email delivery, previews, and similar batch operations.

We are also investigating a major performance degradation and/or elevated error rates that is affecting all Files.com core and auxiliary services in all regions.

We will provide additional details as they become available. Customers with urgent questions are encouraged to contact our Customer Support team by email. Thank you for your patience.
Posted Oct 06, 2023 - 06:16 PDT
This incident affected: Background Jobs, including Sync and Webhooks.