Service Interruption
Incident Report for Files.com
Postmortem

The Incident

On January 25th, 2020, at 8:30 AM PST the Files.com team received internal monitoring alerts, followed by support requests, that customers were unable to access the Files.com application via the web application, API, or any other protocols.

Research indicated there were three separate windows of unavailability:

  • 8:30 - 8:33 AM PST
  • 8:48 - 8:54 AM PST
  • 10:10 - 10:31 AM PST

Extensive testing has been conducted by Files.com staff with no errors detected, and we have already taken steps internally, to prevent this issue from recurring in the future. We greatly appreciate your patience and understanding as we resolved this issue. If you need additional assistance or continue to experience issues, please contact our Customer Success team.

Posted Jan 31, 2020 - 13:55 PST

Resolved
All services have been restored and are operating normally. We identified that there were three interruptions of service totaling 30 minutes beginning at 8:30 am PST - the first being 3 minutes, the second 6 minutes, and the third 21 minutes. As of 10:31 am PST, services were returned to normal. We will follow up with an Incident Report within ten (10) business days including the root cause and steps taken to address the root cause. If you need additional support, please do not hesitate to contact our Customer Success team by email, live chat, or phone. Thanks for your support while we resolved this issue.
Posted Jan 25, 2020 - 08:30 PST